Pimbrook Software

4660: Sage 50 System Requirements V24 (2018)

<< Home
<< Contact Us

Last Modified:
Author: Pimbrook Support

This article lists the system requirements for Sage 50cloud Accounts, Sage 50 Accounts, Sage Instant Accounts and Sage Accountants’ Dataset Manager.

As part of our policy of continued product development, we occasionally release updates to make improvements to the software and address any issues we’ve identified. To ensure your software is up to date, from within your software click Help then click Check For Updates.

Storing Sage Accounts data on non Windows operating systems, for example NAS drives, is not tested and therefore not supported. For more information on non-windows operating systems, please refer to article 24287. For more information on using Sage Software on an Apple Mac, please refer to article 15524.

If your version of Sage Accounts isn’t compatible with your computer, you may need to upgrade your software.

Sage Accounts v24

Supported operating systems

All 32-bit or 64-bit variants of the following operating systems:

Please ensure all the latest Microsoft Service Packs and Updates are installed.

  • Windows 10 (except Windows 10S)
  • Windows 8.1
  • Windows 8
  • Windows 7
  • Windows Server 2016 (except  Windows Server 2016 Essentials)
  • Windows Server 2012 (except  Windows Server 2012 Essentials)
  • Windows Server 2012 R2 (except  Windows Server 2012 R2 Essentials)
  • Windows Server 2008 (not supported on Small Business Server/SBS 2008)
  • Windows Server 2008 R2 (not supported on Small Business Server/SBS 2008)

Microsoft Small Business Server (SBS) 2008 and 2011 – due to a small number of customers seeing performance issues we don’t recommend the use of Microsoft Small Business Server (SBS) 2011 or 2008 with Sage Accounts v24. The installation of Sage Accounts v24 on SBS is blocked by default but, if required, you can still install the software by following the steps in article 32387. For further information on SBS 2011, please refer to article 30792 . We do not support any issues you might have using these operating systems.

Sage Accounts is not tested on virtual environments, for example, Hyper-V servers. We therefore can’t guarantee Sage Accounts will install and work correctly on these environments.

For details of using Sage software on an Apple Mac computer, please refer to article 15524.

Hardware requirements

  • 2 GB RAM (4 GB RAM if running a 64-bit operating system).
  • 2GHz processor or higher.
  • 5GB of free disk space.
  • 1Gbps network (100mbps minimum).
  • Screen resolution between 1024 x 768 and 1920 x 1080 – this applies to 4k and hi-res monitors.
  • Maximum DPI setting of 125%

Sage Accounts v24 requires you to install the Sage Data Service on the machine where your data is held. If this isn’t possible, you won’t be able to share your data on that machine. Although not supported, previous versions may have worked as they didn’t use the Sage Data Service. For more information on storing your data on non-Windows operating systems, please refer to article 24287.

Office integration

Some features of Sage 50 Accounts interact with and require an installation of Microsoft Office.

These features include:

  • Emailing invoices and reports
  • Exporting report and screen lists to excel

The information below relates to the use of these features:

  • Office 64-bit versions – In Sage Accounts v24 you can use the File > Microsoft Integration > Contents to Microsoft Excel feature and also run Excel ODBC queries with Office 64-bit. Other features aren’t compatible.
  • Office 365 32-bit – desktop version only

To check if it’s the desktop version, Control Panel > Program > Default Programs > Set your default programs > check if Microsoft Outlook is the desktop version.

  • Office 2016 32-bit edition
  • Office 2013 32-bit edition
  • Office 2010 32-bit edition*
  • Office 2007

Microsoft Office 2007 and 2010 are no longer supported by Microsoft, therefore we’re limited in the support we can offer. We can help with basic steps, however if these don’t work, you should upgrade your software to a more recent version.

* Not compatible with Office 2010 32-bit starter edition

Sage 50cloud Accounts only

Sage 50cloud Accounts offers additional functionality using Office 365. These features require an Microsoft Office 365 Business Premium or Enterprise E1, E3, or E5 subscription.

The section below confirms the requirements for each element of Sage 50cloud Accounts:

Sage 50cloud Intelligence
  • Excel desktop edition 2013 or 2016
  • Excel online
Sage Contact
  • Outlook desktop edition 2013 or 2016
  • Outlook online (accessed via browser)

Sage Contact does not currently support the native mobile applications for mobile devices.

For further information about Microsoft Office compatibility, please refer to article 32017.

Internet Connection

A broadband Internet connection is essential to keep your Sage software up to date, and to take full advantage of features such as Sage Drive and synchronising data with Office 365.

  • Recommended minimum download speed: 4Mbps
  • Recommended minimum upload speed: 2Mbps

Sage 50cloud Accounts only – Sage Intelligence and Sage Contact make use of online features of Microsoft Office 365. For more details of system requirements, please refer to Microsoft Office 365 system requirements.

Antivirus software

To optimise performance your antivirus software should be configured to exclude Sage files from its checking routines. For further information, please refer to article 12122.

Internet browser

Internet Explorer version 11 or above.

Microsoft .NET

Microsoft .NET Framework 4.6 is required.

Mobile apps

Sage 50 Accounts Tracker app

Sage 50 Accounts Tracker is tested on the following operating systems, but may work with earlier versions:

  • iPhone 5s and above running iOS 11 and above.
  • Android 6.0 (Marshmallow) and above.
Sage 50 Accounts Mobile Sales app

Sage 50 Mobile Sales is tested on the following operating systems, but may work with earlier versions:

  • iPad mini 2 or iPad 5th gen and above running iOS 11 and above.
  • Android 6.0 (Marshmallow) and above.
Sage Capture app

Sage Capture is tested on the following operating systems, but may work with earlier versions:

  • iPhone 5 or above running iOS 9.3 or later.
  • Android 5.0 (Lollipop) and above.

 


Still need help?

<< return to search