• New Sage Payroll Update v27.1 Released
    Includes ERR and CWPS enhancements
  • New Sage Payroll Update v27.1 Released

What’s new in Sage Payroll (Micropay) v27.1

What’s new in Sage Payroll (Micropay) v27.1

Sage has released an update to improve ERR features, validating employees approaching 66, CWPS and ERR History as follows:

1. Enhanced reporting improvements

To help you with the Enhanced Reporting Requirements (ERR), in v27.1 we’ve made the following improvements based on your feedback:

2. Improved validation and messaging for employees approaching 66 years old.

3. CWPS – Fix for exporting file with the incorrect year.

4. Invalid History error when sending corrections following ERR submission. You can amend any new Payroll or ERR submissions made in v27.1.

 

Download and install the latest version of Sage Payroll.